summaryrefslogtreecommitdiff
path: root/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild')
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
new file mode 100644
index 000000000000..89e747db64c5
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r301.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://www.unidata.ucar.edu/downloads/netcdf/ftp/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="3"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND=">=sci-libs/netcdf-4.2:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc -r examples
+ fi
+}