summaryrefslogtreecommitdiff
path: root/sci-libs/mumps/mumps-5.3.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mumps/mumps-5.3.5-r1.ebuild')
-rw-r--r--sci-libs/mumps/mumps-5.3.5-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-libs/mumps/mumps-5.3.5-r1.ebuild b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
index 8e6488b38200..8df93f5e4e8c 100644
--- a/sci-libs/mumps/mumps-5.3.5-r1.ebuild
+++ b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,8 +8,8 @@ inherit fortran-2 flag-o-matic multilib toolchain-funcs
MYP=MUMPS_${PV}
DESCRIPTION="MUltifrontal Massively Parallel sparse direct matrix Solver"
-HOMEPAGE="http://mumps.enseeiht.fr/"
-SRC_URI="http://mumps.enseeiht.fr/${MYP}.tar.gz"
+HOMEPAGE="https://mumps-solver.org/"
+SRC_URI="https://mumps-solver.org/${MYP}.tar.gz"
S="${WORKDIR}/${MYP}"
LICENSE="public-domain"
@@ -63,6 +63,16 @@ static_to_shared() {
}
src_prepare() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862903
+ #
+ # There is an upstream mailing list but it seems to be broken. I *think*,
+ # because it's all in French. I tried and failed to report the bug.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# workaround for gcc10 (bug #743442)
append-fflags $(test-flags-FC -fallow-argument-mismatch)