summaryrefslogtreecommitdiff
path: root/sci-libs/lmfit/lmfit-9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lmfit/lmfit-9.0.ebuild')
-rw-r--r--sci-libs/lmfit/lmfit-9.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/lmfit/lmfit-9.0.ebuild b/sci-libs/lmfit/lmfit-9.0.ebuild
new file mode 100644
index 000000000000..919ba7d7e77a
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-9.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="https://jugit.fz-juelich.de/mlz/lmfit"
+SRC_URI="https://jugit.fz-juelich.de/mlz/lmfit/-/archive/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake.patch
+)