summaryrefslogtreecommitdiff
path: root/sci-libs/libh2o/libh2o-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libh2o/libh2o-9999.ebuild')
-rw-r--r--sci-libs/libh2o/libh2o-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/libh2o/libh2o-9999.ebuild b/sci-libs/libh2o/libh2o-9999.ebuild
new file mode 100644
index 000000000000..2413fb4aaf6a
--- /dev/null
+++ b/sci-libs/libh2o/libh2o-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Library of routines for IF97 water & steam properties"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2o/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}