summaryrefslogtreecommitdiff
path: root/sci-libs/libexcelformat
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libexcelformat')
-rw-r--r--sci-libs/libexcelformat/Manifest3
-rw-r--r--sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch13
-rw-r--r--sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild (renamed from sci-libs/libexcelformat/libexcelformat-101016.ebuild)14
3 files changed, 21 insertions, 9 deletions
diff --git a/sci-libs/libexcelformat/Manifest b/sci-libs/libexcelformat/Manifest
index 2fee5498c172..7b6a209dd3e0 100644
--- a/sci-libs/libexcelformat/Manifest
+++ b/sci-libs/libexcelformat/Manifest
@@ -1,3 +1,4 @@
+AUX libexcelformat-101016-Wliteral-suffix.patch 309 BLAKE2B a7dd2bd4eabd63a3dcf1f10235266ccead603053a179898b8cc7d13c15552b98b4b6ca91705dd5346ffc288fd938c4177d44898e1222ee43abe5b2442dc689ba SHA512 d739e8b2805abe522341fd945d9adb2c7a41c3b47343c3eff164067066558d54714300a4b1b63665dd8058ce973009963163616ea8298a412eeae1294e03c5a0
DIST libexcelformat-101016.tar.bz2 47980 BLAKE2B 6b6d003d5322d66193655c506e6841af5c3a826558c3f15c9253078975d2d1138f6173753bdc35ec27c6030e23ed76463cc396d6fd0923cdfcc34daf4fd2db84 SHA512 40d43e7b0c15d00026fde3927b3f6fdf9ea110c43141f1a25f3a8ed9ccf6a2acd1de68e25fc54d0c030364d4a4e300aa267332b9d2ac0fb0a422858715156576
-EBUILD libexcelformat-101016.ebuild 551 BLAKE2B 8a80c008837ea7c29a91c2b2d9505f1f7deb8cc796a2d5d1e84913d299206734fff0ae57e94398dec15c24d7ae3abb2ae4e56c2b88b410f2579be799bc090445 SHA512 48d2bc44cebb07a8ae7236a471ba8bb2d38ea08e044e094261de68af6e9f074c9b48997333d7cb67d8eff28c426f2b6faffdc53164889b34f74100f910f0888e
+EBUILD libexcelformat-101016-r1.ebuild 588 BLAKE2B 9c365c4d9c6f7c1e1147f88a9715fe3364fbf8b9aaa669b6234ac62b7392048b533fa75ef302d2f36a12a2cd39d2eaad48ff664f7e78110faf0c5c230454e921 SHA512 a9b3fa15d00b0b30506d9e5ccd1bb12d794f4178745fb4c17f3db573e07baa83473cb8b9d71c7e3f0de07c9eb935498225cf2c08c200235c9187a6bbe16ba48e
MISC metadata.xml 254 BLAKE2B b855316ec6a32691e84730979c9a077765d46802f09c19f3a06f2cddf677674c9a2ea24c9b57a0fc6344d7f70276ca507a68f5fa690555360665ac494fca54c2 SHA512 5f6faacd216c7ece09e847c09115add5261e7a899e0b0c9304f2ee72e2d0ad208338939e4e37946008bdc81fbbacf415fb220c5c1f9832b17f18c6778d0c0368
diff --git a/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch b/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch
new file mode 100644
index 000000000000..9ce8f4a7aa85
--- /dev/null
+++ b/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch
@@ -0,0 +1,13 @@
+Fix -Wliteral-suffix (#731886)
+
+--- a/BasicExcel.cpp
++++ b/BasicExcel.cpp
+@@ -4913,7 +4913,7 @@
+ do
+ {
+ char sname[50];
+- sprintf(sname, "Sheet"FMT_SIZE_T, sheetNo++);
++ sprintf(sname, "Sheet" FMT_SIZE_T, sheetNo++);
+ yesheet = AddWorksheet(sname, sheetIndex);
+ } while (!yesheet);
+ return yesheet;
diff --git a/sci-libs/libexcelformat/libexcelformat-101016.ebuild b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
index c3014bcdc051..23fb0ef4f630 100644
--- a/sci-libs/libexcelformat/libexcelformat-101016.ebuild
+++ b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
@@ -1,28 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
HOMEPAGE="https://www.codeproject.com/Articles/42504/ExcelFormat-Library"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}/libExcelFormat"
+LICENSE="CPOL"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="CPOL"
-IUSE=""
-S="${WORKDIR}"/libExcelFormat
+PATCHES=( "${FILESDIR}"/${P}-Wliteral-suffix.patch )
-src_prepare() {
- default
+src_configure() {
tc-export CXX
}
src_install() {
doheader *.h*
-
dolib.so libExcelFormat.so*
}