summaryrefslogtreecommitdiff
path: root/sci-libs/ldl
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ldl')
-rw-r--r--sci-libs/ldl/Manifest4
-rw-r--r--sci-libs/ldl/ldl-3.0.3.ebuild62
-rw-r--r--sci-libs/ldl/metadata.xml3
3 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/ldl/Manifest b/sci-libs/ldl/Manifest
index ffbc86051cf2..9f389653310b 100644
--- a/sci-libs/ldl/Manifest
+++ b/sci-libs/ldl/Manifest
@@ -1,3 +1,5 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST ldl-2.2.6.tar.bz2 342923 BLAKE2B 7acf1a82824de013fe9a7742fb2d5c44c86de96e95d1d7408106d4af420dc3655ab7533eb80592b52523245c7545bc246bf129712547ff6eba856a807c78b6ad SHA512 266c9e62c474a6a9b2d7f74aa580e313fbe4b322197236ba6fbbab6d1756348cf146c1d807ea6d8d0e5941cedc48298e8437aaf386dd6c433dcaf41a9d0b7371
EBUILD ldl-2.2.6.ebuild 630 BLAKE2B aff0e66113bbd9b3263546478f9d203195bf466b808f16e8666b16f58b531e0c1d125128e70fcbb08f67fff9e1c175d35384a5347c4159b63146ed2c0be1fbe1 SHA512 875dc208fd53e328cb26d7a9ef4f6049363d528f6bd23eb9b85e2b4541ff95597a2bd599a4801f67faf81b5c999ca7d6e7ff4a8ff7fc03095e7976ba55d56bd8
-MISC metadata.xml 892 BLAKE2B 20338f1ef6872e6318a2ee0bb3365c07e1fb5dd06289f7aeac32c3412626580075735ef97aff5f3ec9ce92ec82f6d1c155cc01fe49552349879164aaddd59d45 SHA512 c8a9418875ab2b71be0f6fa5023641b650ac6a897e1c04b6facc97e16eb5c83433908cd2e9e56aecc8a67712c150e6af1d8273d56ead415ffd45e76f83f71f90
+EBUILD ldl-3.0.3.ebuild 1472 BLAKE2B 75973375ffeb080f519b6800e028f3374207295ffe8516fa5a83ed0b8ed857e102767e20c03258943ed61d55c49bd14dfe22b54822178506d3f3a4fdf8701392 SHA512 7bc617e5d01a148dd1427fd78ad7d5eaf4406157d1e8024ac2b1dce81c31db4b3679f53e03298fae9bde63687e0d87639478892796acd69b5a9bdd0ce7242d1d
+MISC metadata.xml 988 BLAKE2B 9a426dc113fa58a0e8223cb07516661f8f315c5981710dfe896bc06b6af205335a29256af84ac91062d60c7db10f0ed1ab93a9f108122bb49702cdd7ffde82af SHA512 9a2d374d4fe958d2655053d4f7f224d7e649ab5402bade0b3622e4035c4348a1c9d3b86d5151b06f760a46a3f29e326762edc70c33b67e8a4664e28579e2c18f
diff --git a/sci-libs/ldl/ldl-3.0.3.ebuild b/sci-libs/ldl/ldl-3.0.3.ebuild
new file mode 100644
index 000000000000..28b394008845
--- /dev/null
+++ b/sci-libs/ldl/ldl-3.0.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}
+ >=sci-libs/amd-3.0.3"
+RDEPEND="${DEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DDEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Some programs assume that they can access the Matrix folder in ${S}
+ ln -s "${S}/Matrix" || die "cannot link to the Matrix folder"
+ # Run demo files
+ local demofiles=(
+ ldlsimple
+ ldllsimple
+ ldlmain
+ ldllmain
+ ldlamd
+ ldllamd
+ )
+ for i in ${demofiles[@]}; do
+ ./"${i}" > "${i}.out" || die "failed to run test ${i}"
+ diff "${S}/Demo/${i}.out" "${i}.out" || die "failed testing ${i}"
+ done
+}
+
+multilib_src_install() {
+ if use doc; then
+ pushd "${S}/Doc"
+ rm -rf *.pdf
+ emake
+ popd
+ DOCS="${S}/Doc/*.pdf"
+ fi
+ cmake_src_install
+}
diff --git a/sci-libs/ldl/metadata.xml b/sci-libs/ldl/metadata.xml
index e6396c0864b0..c450822b982c 100644
--- a/sci-libs/ldl/metadata.xml
+++ b/sci-libs/ldl/metadata.xml
@@ -16,4 +16,7 @@
consists of a total of only 49 lines of code. The package is written
in C, and includes a MATLAB interface.
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>