summaryrefslogtreecommitdiff
path: root/sci-libs/kineto/kineto-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/kineto/kineto-0.4.0.ebuild')
-rw-r--r--sci-libs/kineto/kineto-0.4.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/kineto/kineto-0.4.0.ebuild b/sci-libs/kineto/kineto-0.4.0.ebuild
new file mode 100644
index 000000000000..60ac97c00887
--- /dev/null
+++ b/sci-libs/kineto/kineto-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 cmake
+
+DESCRIPTION="part of the PyTorch Profiler"
+HOMEPAGE="https://github.com/pytorch/kineto"
+SRC_URI="https://github.com/pytorch/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libfmt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ ${PYTHON_DEPS}
+"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-2021.11.17-gentoo.patch
+ cd libkineto
+ cmake_src_prepare
+}
+
+src_configure() {
+ cd libkineto
+ cmake_src_configure
+}