summaryrefslogtreecommitdiff
path: root/sci-libs/ipopt
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ipopt')
-rw-r--r--sci-libs/ipopt/Manifest4
-rw-r--r--sci-libs/ipopt/ipopt-3.14.4.ebuild76
-rw-r--r--sci-libs/ipopt/metadata.xml26
3 files changed, 94 insertions, 12 deletions
diff --git a/sci-libs/ipopt/Manifest b/sci-libs/ipopt/Manifest
index b61a390f57f3..8ce8a33e78c4 100644
--- a/sci-libs/ipopt/Manifest
+++ b/sci-libs/ipopt/Manifest
@@ -1,3 +1,5 @@
DIST Ipopt-3.12.12.tgz 4530034 BLAKE2B 8a8e24e4e5d8ad5bc1fcfa2de525e1e39c88a4c6dd77b51c0549249f517b3d6a1279e355a7cb606ebd8e606551031b653b78cd4d1cb51dd369e051ffa010011f SHA512 c543695feaa39a69b01e0025ebcd8a8772deb369ea1072f17da4ba34c1b522d322959067f3a6cfc40446e00c2e6dd2d6704a55623aba5d61dff44333727368cb
+DIST ipopt-3.14.4.tar.gz 1843885 BLAKE2B 83f6a983db282ced6e52237ff326c860a92df2c92dbd53db7581110d3003fd7b557a68453c74e48d780832d2c9c55d9eb4ea54e68f504c161952fce6bb81caaf SHA512 a27a08ae24c94da96efcfa236034cec79d79111d7dc9c028d808b412d5abb21495a0011f075a87db65b91ba69e191653552e7f99fe8da88c3b580d971eac3652
EBUILD ipopt-3.12.12.ebuild 2080 BLAKE2B 2c3fa37450613d141645906d21c5776064bb6bd6a862014000f99862c7bad432387f43b25dce44667e71ec19fbe0d52a9995ce86c374222510b55bc8c69bbf48 SHA512 52656a3149d8f7582cdd5157faea9c034fc27d436abb5b5de7859361310daebe461c560c9efab87a9cef9abca36247e0db322a828d482c3a63cf822d16f683d3
-MISC metadata.xml 843 BLAKE2B 4eac8500ceabe46f61acbb6dd928503ce4b9e80e7e5c3c239f8dbffba97eda36c02bb6fd776e50e5281d9b9054e5454609b431176dda147341c8e1ad6ebc0046 SHA512 007cd4d7195111e24000d5145db3431ff64a209111523a1f911fb00281119adccc65c2a3f02e7449cea5a161907f18395c50dee4b97e684d493902b472334afa
+EBUILD ipopt-3.14.4.ebuild 1734 BLAKE2B 25133ba41dab04662c53ed268e4e8392307e1a0012f168f65ee64fe75c70c7f8ad37065ffc5dcbccfc5d1dfa44ddaa542321fd181e98de4b5aaa47e65e95fd3b SHA512 e9fcd4f104fc8df872c0eae55bb6b4b748728136dc35745d00ebe1bc71f97c2d13d2a3b77981afc2e6d305fd34b0a7d6d613c4c600a53242630ec97f7e580015
+MISC metadata.xml 967 BLAKE2B 8a3fc8addf0130148ddca1bcfb4732e1bf60b52d5de28e2ee6ce9b8e4352358424b39aa585ba177592b4a5744bf2f52e16ab393e2a80617333a48e385eb55a2d SHA512 aa538e824ce3cc926f28554dc268f6d109bebd382b35bb2db8aee75fa82cc81bf9171ace022aaf441602bf8b150fa7bf80ad04e4563d2c3b83e25d80d8780574
diff --git a/sci-libs/ipopt/ipopt-3.14.4.ebuild b/sci-libs/ipopt/ipopt-3.14.4.ebuild
new file mode 100644
index 000000000000..6a2bac46ff03
--- /dev/null
+++ b/sci-libs/ipopt/ipopt-3.14.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED="mumps"
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+DOCS_DEPEND="media-gfx/graphviz"
+
+inherit docs fortran-2 toolchain-funcs
+
+DESCRIPTION="Interior-Point Optimizer for large-scale nonlinear optimization"
+HOMEPAGE="https://github.com/coin-or/Ipopt"
+SRC_URI="https://github.com/coin-or/Ipopt/archive/refs/tags/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Ipopt-releases-${PV}"
+
+LICENSE="EPL-1.0 hsl? ( HSL )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="hsl +lapack mpi mumps static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/blas
+ hsl? ( sci-libs/coinhsl:0= )
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi )
+ mumps? ( sci-libs/mumps:0=[mpi=] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample sci-libs/mumps )"
+
+src_prepare() {
+ if use mpi ; then
+ export CXX=mpicxx FC=mpif77 F77=mpif77 CC=mpicc
+ fi
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc dot)
+ )
+
+ if use lapack; then
+ myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include$(usex mpi '' '/mpiseq')
+ --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+ if use hsl; then
+ myeconfargs+=(
+ --with-hsl-incdir="${EPREFIX}"/usr/include
+ --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
+ else
+ myeconfargs+=( --without-hsl )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ dodoc -r examples
+}
diff --git a/sci-libs/ipopt/metadata.xml b/sci-libs/ipopt/metadata.xml
index 465f5eae75b3..f5b474167afc 100644
--- a/sci-libs/ipopt/metadata.xml
+++ b/sci-libs/ipopt/metadata.xml
@@ -2,20 +2,24 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
- Ipopt is a solver for large-scale nonlinear continuous
- optimization. It can be used from modeling environments, such as
- AMPL, GAMS, or Matlab, and it is also available as a callable library with
- interfaces to C++, C, and Fortran. Ipopt uses an interior point
- method, together with a filter linear search procedure. Ipopt is
- part of the larger COIN-OR initiative (Computational Infrastructure
- for Operations Research).
+ Ipopt is a solver for large-scale nonlinear continuous
+ optimization. It can be used from modeling environments, such as
+ AMPL, GAMS, or Matlab, and it is also available as a callable library with
+ interfaces to C++, C, and Fortran. Ipopt uses an interior point
+ method, together with a filter linear search procedure. Ipopt is
+ part of the larger COIN-OR initiative (Computational Infrastructure
+ for Operations Research).
</longdescription>
<use>
- <flag name="hsl">hsl</flag>
- <flag name="mumps">Enable <pkg>sci-libs/mumps</pkg> support</flag>
+ <flag name="hsl">hsl</flag>
+ <flag name="mumps">Enable <pkg>sci-libs/mumps</pkg> support</flag>
</use>
+<upstream>
+ <bugs-to>https://github.com/coin-or/Ipopt/issues</bugs-to>
+ <remote-id type="github">coin-or/Ipopt</remote-id>
+</upstream>
</pkgmetadata>