summaryrefslogtreecommitdiff
path: root/sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild')
-rw-r--r--sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild b/sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild
new file mode 100644
index 000000000000..53cc4aff4637
--- /dev/null
+++ b/sci-libs/idlcoyote/idlcoyote-20161220-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/coyote"
+ BDEPEND="app-arch/unzip"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/idl-coyote/coyote.git"
+fi
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ dodoc README.txt
+ rm README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}