summaryrefslogtreecommitdiff
path: root/sci-libs/hipSOLVER
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hipSOLVER')
-rw-r--r--sci-libs/hipSOLVER/Manifest3
-rw-r--r--sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild35
-rw-r--r--sci-libs/hipSOLVER/metadata.xml19
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/hipSOLVER/Manifest b/sci-libs/hipSOLVER/Manifest
new file mode 100644
index 000000000000..6c96ae23564d
--- /dev/null
+++ b/sci-libs/hipSOLVER/Manifest
@@ -0,0 +1,3 @@
+DIST hipSOLVER-rocm-5.7.1.tar.gz 1516012 BLAKE2B 8d0966d34877978784b9872150283719602465c85036c3a74a72a2fe7c516b6029af3f4aefbc022088b2cf37bb1e0a450c0221aef0ac3227018020de340adfcd SHA512 f9c14b51ea582f17d1b323c7d066d9c0c95f4250f08515768d7a11067774fd2841fa3dec7354d3c98e56bd8dd53cff3b993c68b1d7df4b24f562b3afe9c4625e
+EBUILD hipSOLVER-5.7.1.ebuild 820 BLAKE2B 2e172aea78616bb75696b6dcf81e7ebee8902ff15335a5d7d36e9728e74eb20c320124491bccfb6cef9b4804e14fd7c58accacce500d13c043f6a104407f0c77 SHA512 83d99abbb856cfe7ce029fd8c7529fdd07be56e60a4ce6f00b662c5a6c3c829e99e66081fa907e61ee673320991fcbccca26b493022cdcae5e6d12dac04b62ea
+MISC metadata.xml 618 BLAKE2B a62e9c459afe2c341849d43f9dbf2304389dfa1f50ace6616c5bd2903488e49d0e1d235808a46dafb782d638a3f209706220d66264fda845b701c19e55febce2 SHA512 c9654b6e8a610638093d3f26710292cf62e0d9e1a9dddc160c4d30e59e7a12f70e39eb965995187fe54b6f3648fb44810ca8b983a886af7a731d62eb06c9464b
diff --git a/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild b/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild
new file mode 100644
index 000000000000..fc195db69e10
--- /dev/null
+++ b/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic marshalling library for LAPACK routines on the GPU"
+HOMEPAGE="https://github.com/ROCm/hipSOLVER"
+SRC_URI="https://github.com/ROCm/hipSOLVER/archive/refs/tags/rocm-${PV}.tar.gz -> hipSOLVER-rocm-${PV}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/hipSOLVER-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}
diff --git a/sci-libs/hipSOLVER/metadata.xml b/sci-libs/hipSOLVER/metadata.xml
new file mode 100644
index 000000000000..dfd45574f216
--- /dev/null
+++ b/sci-libs/hipSOLVER/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/hipSOLVER</remote-id>
+ </upstream>
+</pkgmetadata>