summaryrefslogtreecommitdiff
path: root/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild')
-rw-r--r--sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild b/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild
new file mode 100644
index 000000000000..fc195db69e10
--- /dev/null
+++ b/sci-libs/hipSOLVER/hipSOLVER-5.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic marshalling library for LAPACK routines on the GPU"
+HOMEPAGE="https://github.com/ROCm/hipSOLVER"
+SRC_URI="https://github.com/ROCm/hipSOLVER/archive/refs/tags/rocm-${PV}.tar.gz -> hipSOLVER-rocm-${PV}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/hipSOLVER-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}