summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5/hdf5-1.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.12.1.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.12.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-libs/hdf5/hdf5-1.12.1.ebuild b/sci-libs/hdf5/hdf5-1.12.1.ebuild
index c5ef043111b3..8248d6614f5a 100644
--- a/sci-libs/hdf5/hdf5-1.12.1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.12.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED="fortran"
-inherit cmake flag-o-matic fortran-2
+inherit cmake flag-o-matic fortran-2 toolchain-funcs
MY_P="${PN}-${PV/_p/-patch}"
MAJOR_P="${PN}-$(ver_cut 1-2)"
@@ -62,6 +62,7 @@ pkg_setup() {
}
src_configure() {
+ use sparc && tc-is-gcc && append-flags -fno-tree-ccp # bug 686620
local mycmakeargs=(
-DBUILD_STATIC_LIBS=OFF
-DFETCHCONTENT_FULLY_DISCONNECTED=ON