summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.12.1-r1.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.12.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild b/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
index a445755a1291..32a8891c8155 100644
--- a/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED="fortran"
-inherit cmake flag-o-matic fortran-2
+inherit cmake flag-o-matic fortran-2 toolchain-funcs
MY_P="${PN}-${PV/_p/-patch}"
MAJOR_P="${PN}-$(ver_cut 1-2)"
@@ -16,7 +16,7 @@ SRC_URI="https://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="cxx debug doc examples fortran +hl mpi ros3 szip test threads unsupported zlib"
REQUIRED_USE="
@@ -66,6 +66,7 @@ pkg_setup() {
}
src_configure() {
+ use sparc && tc-is-gcc && append-flags -fno-tree-ccp # bug 686620
local mycmakeargs=(
# Workaround needed to allow build with USE=fortran when an older
# version is installed. See bug #808633 and