summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.14.4-0001-Make-sure-that-during-runtime-we-ll-use-the-same-lib.patch28
-rw-r--r--sci-libs/hdf5/files/hdf5-1.14.4-0002-Disable-forced-stripping.patch31
-rw-r--r--sci-libs/hdf5/files/hdf5-1.14.4-0003-Drop-broken-Werror-stripping.patch65
3 files changed, 124 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.14.4-0001-Make-sure-that-during-runtime-we-ll-use-the-same-lib.patch b/sci-libs/hdf5/files/hdf5-1.14.4-0001-Make-sure-that-during-runtime-we-ll-use-the-same-lib.patch
new file mode 100644
index 000000000000..5b3a5f85f2ce
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.14.4-0001-Make-sure-that-during-runtime-we-ll-use-the-same-lib.patch
@@ -0,0 +1,28 @@
+From dcfab0f9f0c41cb61a25b11cd61eac7204365693 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 17 Dec 2023 09:25:43 +0000
+Subject: [PATCH 1/3] Make sure that during runtime we'll use the same
+ libgfortran as during linking
+
+Bug: https://bugs.gentoo.org/419991
+Bug: https://bugs.gentoo.org/419895
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ fortran/src/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
+index 8d8396f..de03df9 100644
+--- a/fortran/src/Makefile.am
++++ b/fortran/src/Makefile.am
+@@ -98,6 +98,7 @@ if BUILD_PARALLEL_CONDITIONAL
+ else
+ H5FC_NAME = h5fc
+ endif
++H5test_kind_LDFLAGS=-static-libgfortran
+
+ # Rules for automatically detecting which fortran types are present
+ # and matching them to C types. This is accomplished using helper
+--
+2.44.0
+
diff --git a/sci-libs/hdf5/files/hdf5-1.14.4-0002-Disable-forced-stripping.patch b/sci-libs/hdf5/files/hdf5-1.14.4-0002-Disable-forced-stripping.patch
new file mode 100644
index 000000000000..25a3088dc031
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.14.4-0002-Disable-forced-stripping.patch
@@ -0,0 +1,31 @@
+From 9bcb00e44ce2442db9dcd173e70f8635d7e22c1d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 17 Dec 2023 09:26:33 +0000
+Subject: [PATCH 2/3] Disable forced stripping
+
+Bug: https://bugs.gentoo.org/665378
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6a3beee..fc44a39 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2512,9 +2512,9 @@ case "X-$SYMBOLS" in
+ AC_MSG_RESULT([yes])
+ ;;
+ X-no)
+- H5_CFLAGS="$H5_CFLAGS $NO_SYMBOLS_CFLAGS"
+- H5_CXXFLAGS="$H5_CXXFLAGS $NO_SYMBOLS_CXXFLAGS"
+- H5_FCFLAGS="$H5_FCFLAGS $NO_SYMBOLS_FCFLAGS"
++ H5_CFLAGS="$H5_CFLAGS"
++ H5_CXXFLAGS="$H5_CXXFLAGS"
++ H5_FCFLAGS="$H5_FCFLAGS"
+ AC_MSG_RESULT([no])
+ ;;
+ *)
+--
+2.44.0
+
diff --git a/sci-libs/hdf5/files/hdf5-1.14.4-0003-Drop-broken-Werror-stripping.patch b/sci-libs/hdf5/files/hdf5-1.14.4-0003-Drop-broken-Werror-stripping.patch
new file mode 100644
index 000000000000..3b8a628b0384
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.14.4-0003-Drop-broken-Werror-stripping.patch
@@ -0,0 +1,65 @@
+From 014f4857dc0e5883cb07393d5875412806855d28 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 17 Dec 2023 09:27:18 +0000
+Subject: [PATCH 3/3] Drop broken -Werror stripping
+
+The stripping is broken and mangles -Werror=x -> -x [0].
+
+[0] https://github.com/HDFGroup/hdf5/commit/41526f68f3482f2b3a7aa581288bc86e9c6dcb43#r100076265
+
+Bug: https://bugs.gentoo.org/917448
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac | 36 ------------------------------------
+ 1 file changed, 36 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fc44a39..2117303 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -193,42 +193,6 @@ saved_user_JAVAFLAGS="$JAVAFLAGS"
+ saved_user_LDFLAGS="$LDFLAGS"
+ saved_user_CPPFLAGS="$CPPFLAGS"
+
+-## Strip out -Werror from CFLAGS since that can cause checks to fail when
+-## compiling test programs fails due to warnings
+-##
+-## Regex:
+-##
+-## -Werror Literal -Werror
+-## \( Start optional capturing group
+-## = Literal equals sign
+-## [^[:space:]] Non-space characters
+-## \+ 1 or more of the above
+-## \) End optional capturing group
+-## \? 0 or 1 capturing group matches
+-##
+-## Note that the outer pair of '[]' ends up getting removed
+-WERROR_SED='s/-Werror\(=[[^[:space:]]]\+\)\?//g'
+-CFLAGS_SED="`echo $CFLAGS | sed -e $WERROR_SED`"
+-if test $? -eq 0; then
+- CFLAGS="$CFLAGS_SED"
+-fi
+-CXXFLAGS_SED="`echo $CXXFLAGS | sed -e $WERROR_SED`"
+-if test $? -eq 0; then
+- CXXFLAGS="$CXXFLAGS_SED"
+-fi
+-FCFLAGS_SED="`echo $FCFLAGS | sed -e $WERROR_SED`"
+-if test $? -eq 0; then
+- FCFLAGS="$FCFLAGS_SED"
+-fi
+-JAVACFLAGS_SED="`echo $JAVACFLAGS | sed -e $WERROR_SED`"
+-if test $? -eq 0; then
+- JAVACFLAGS="$JAVACFLAGS_SED"
+-fi
+-CPPFLAGS_SED="`echo $CPPFLAGS | sed -e $WERROR_SED`"
+-if test $? -eq 0; then
+- CPPFLAGS="$CPPFLAGS_SED"
+-fi
+-
+ ## Support F9X variable to define Fortran compiler if FC variable is
+ ## not used. This should be deprecated in the future.
+ if test "x" = "x$FC"; then
+--
+2.44.0
+