summaryrefslogtreecommitdiff
path: root/sci-libs/h5part/h5part-1.6.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/h5part/h5part-1.6.6-r1.ebuild')
-rw-r--r--sci-libs/h5part/h5part-1.6.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/h5part/h5part-1.6.6-r1.ebuild b/sci-libs/h5part/h5part-1.6.6-r1.ebuild
new file mode 100644
index 000000000000..388a4fe89c55
--- /dev/null
+++ b/sci-libs/h5part/h5part-1.6.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P^^[hp]}"
+DESCRIPTION="Portable High Performance Parallel Data Interface to HDF5"
+HOMEPAGE="https://vis.lbl.gov/archive/Research/H5Part/"
+SRC_URI="https://codeforge.lbl.gov/frs/download.php/latestfile/18/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/mpi
+ sci-libs/hdf5:=[mpi]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-mpio.patch" )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --enable-parallel --enable-shared --disable-static CC=mpicc CXX=mpicxx
+}