summaryrefslogtreecommitdiff
path: root/sci-libs/ginkgo/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ginkgo/files')
-rw-r--r--sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch24
-rw-r--r--sci-libs/ginkgo/files/ginkgo-1.6.0-fix_type_mismatch.patch12
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch b/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch
new file mode 100644
index 000000000000..c910ad92c5a9
--- /dev/null
+++ b/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch
@@ -0,0 +1,24 @@
+diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
+index 41ed77d900..9a0c7d5128 100644
+--- a/examples/CMakeLists.txt
++++ b/examples/CMakeLists.txt
+@@ -40,8 +40,7 @@ if(GINKGO_BUILD_EXTLIB_EXAMPLE)
+ list(APPEND EXAMPLES_LIST external-lib-interfacing)
+ endif()
+
+-find_package(OpenCV QUIET)
+-if(OpenCV_FOUND)
++if(FALSE)
+ list(APPEND EXAMPLES_LIST heat-equation schroedinger-splitting)
+ else()
+ message(STATUS "No OpenCV found, disabling examples with video output")
+@@ -55,8 +54,7 @@ if(GINKGO_BUILD_MPI)
+ list(APPEND EXAMPLES_LIST distributed-solver)
+ endif()
+
+-find_package(Kokkos QUIET)
+-if(Kokkos_FOUND)
++if(FALSE)
+ if(GINKGO_WITH_CCACHE)
+ message(WARNING "The CMAKE_CXX_COMPILER_LAUNCHER is set due to "
+ "GINKGO_WITH_CCACHE=ON which is known to casue issues with CUDA enabled "
diff --git a/sci-libs/ginkgo/files/ginkgo-1.6.0-fix_type_mismatch.patch b/sci-libs/ginkgo/files/ginkgo-1.6.0-fix_type_mismatch.patch
new file mode 100644
index 000000000000..d248fe87f2d7
--- /dev/null
+++ b/sci-libs/ginkgo/files/ginkgo-1.6.0-fix_type_mismatch.patch
@@ -0,0 +1,12 @@
+diff --git a/core/base/timer.cpp b/core/base/timer.cpp
+index bc1c716..0185567 100644
+--- a/core/base/timer.cpp
++++ b/core/base/timer.cpp
+@@ -124,7 +124,7 @@ void CpuTimer::wait(time_point& time) {}
+ std::chrono::nanoseconds CpuTimer::difference_async(const time_point& start,
+ const time_point& stop)
+ {
+- return std::chrono::duration_cast<std::chrono::nanoseconds, int64>(
++ return std::chrono::duration_cast<std::chrono::nanoseconds>(
+ stop.data_.chrono - start.data_.chrono);
+ }