summaryrefslogtreecommitdiff
path: root/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch')
-rw-r--r--sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch b/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch
new file mode 100644
index 000000000000..c910ad92c5a9
--- /dev/null
+++ b/sci-libs/ginkgo/files/ginkgo-1.6.0-disable_automagic_dependencies.patch
@@ -0,0 +1,24 @@
+diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
+index 41ed77d900..9a0c7d5128 100644
+--- a/examples/CMakeLists.txt
++++ b/examples/CMakeLists.txt
+@@ -40,8 +40,7 @@ if(GINKGO_BUILD_EXTLIB_EXAMPLE)
+ list(APPEND EXAMPLES_LIST external-lib-interfacing)
+ endif()
+
+-find_package(OpenCV QUIET)
+-if(OpenCV_FOUND)
++if(FALSE)
+ list(APPEND EXAMPLES_LIST heat-equation schroedinger-splitting)
+ else()
+ message(STATUS "No OpenCV found, disabling examples with video output")
+@@ -55,8 +54,7 @@ if(GINKGO_BUILD_MPI)
+ list(APPEND EXAMPLES_LIST distributed-solver)
+ endif()
+
+-find_package(Kokkos QUIET)
+-if(Kokkos_FOUND)
++if(FALSE)
+ if(GINKGO_WITH_CCACHE)
+ message(WARNING "The CMAKE_CXX_COMPILER_LAUNCHER is set due to "
+ "GINKGO_WITH_CCACHE=ON which is known to casue issues with CUDA enabled "