summaryrefslogtreecommitdiff
path: root/sci-libs/geos/geos-3.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/geos/geos-3.12.1.ebuild')
-rw-r--r--sci-libs/geos/geos-3.12.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/geos/geos-3.12.1.ebuild b/sci-libs/geos/geos-3.12.1.ebuild
index 3cd12a9122d1..71105c249023 100644
--- a/sci-libs/geos/geos-3.12.1.ebuild
+++ b/sci-libs/geos/geos-3.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="https://libgeos.org/"
@@ -18,6 +18,11 @@ RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862702
+ # https://github.com/libgeos/geos/issues/1054
+ filter-lto
+
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_TESTING=$(usex test)