summaryrefslogtreecommitdiff
path: root/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch')
-rw-r--r--sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch b/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch
new file mode 100644
index 000000000000..837a50f6b825
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch
@@ -0,0 +1,23 @@
+From 60dcddbf5fab917338caf433b3e7dca283cf9720 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Thu, 4 Apr 2024 17:48:33 +0200
+Subject: [PATCH] Fix build with Poppler 24.05 (unreleased yet)
+
+---
+ frmts/pdf/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/frmts/pdf/CMakeLists.txt b/frmts/pdf/CMakeLists.txt
+index 9b9a1898a730..bcb19c3aa24c 100644
+--- a/frmts/pdf/CMakeLists.txt
++++ b/frmts/pdf/CMakeLists.txt
+@@ -54,6 +54,9 @@ if (GDAL_USE_POPPLER)
+ if ("${Poppler_VERSION_MINOR}" MATCHES "0?[0-9]+")
+ string(REGEX REPLACE "0?([0-9]+)" "\\1" Poppler_VERSION_MINOR ${Poppler_VERSION_MINOR})
+ endif ()
++ if (Poppler_VERSION_STRING VERSION_GREATER_EQUAL "24.05")
++ target_compile_features(gdal_PDF PRIVATE cxx_std_20)
++ endif ()
+ target_compile_definitions(gdal_PDF PRIVATE -DHAVE_POPPLER -DPOPPLER_MAJOR_VERSION=${Poppler_VERSION_MAJOR}
+ -DPOPPLER_MINOR_VERSION=${Poppler_VERSION_MINOR})
+ endif ()