summaryrefslogtreecommitdiff
path: root/sci-libs/dsdp
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/dsdp')
-rw-r--r--sci-libs/dsdp/Manifest1
-rw-r--r--sci-libs/dsdp/dsdp-5.8-r3.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-libs/dsdp/Manifest b/sci-libs/dsdp/Manifest
index f0519c240062..f51571ebb4cc 100644
--- a/sci-libs/dsdp/Manifest
+++ b/sci-libs/dsdp/Manifest
@@ -2,6 +2,5 @@ AUX dsdp-5.8-gold.patch 342 BLAKE2B a0cc333fed3f2b1ebdeccc439c0b98f9956bc64ac105
AUX dsdp-5.8-malloc.patch 212 BLAKE2B d030d01bc49aa275c2f0eed48c1808e17877120587dedcf72fb07f737e44953df8c28d2ba6a5a443b372f56c036f9f44e1841a209b383ddab892ff8ef4e0f01d SHA512 a4c324beadb7298c9c8709115c83975d10b359b792042047439631f478fc99648b9348715645cd34d893fe9b6b49b6ba8e628771cde0e007eb0b1f474dd1fd7f
AUX dsdp-5.8-readsdpa.patch 495 BLAKE2B 538ca4b9986cb5ed74ecb8510f8de23ecace871111140d394ae982e9932b9a733f2355199deb28cdf88addd0e18939b6a4e22b737a65438dc12e0a36e93d885c SHA512 43b329526f3b7d4761f7dfa44d62f94a843491bf9998f2f839edc880cdd8d04d1c8c7187213eda887025a9f3cdbff19afba6720cd2d70580b0e2dcb9512f8f90
DIST DSDP5.8.tar.gz 2608518 BLAKE2B d464db2956080a33c300520ed291e1b45aeedd28378d5aab753977688bfe74d953f1d40a7aa10c2af8b70808d97dc5ece0c98d2795f707a9a3d2128302658286 SHA512 0a32a34e33dcac151e95ed0f8cee62603bbe2b4ba1e448bba35324fe576376cb33c15908cde61ae5a7c0dcdea945f1ec544f19b3dd36524158573260182e080e
-EBUILD dsdp-5.8-r3.ebuild 2378 BLAKE2B c2784ecc2ad26007e429f0d56c4970e2d8a193fd6361d1a126d17bf56ea270910eb6fb29763f6ccd4dc3ff8eabb0fd6db07d92ea2e44880a65f218692f1cb26f SHA512 caee48d512e128819b3ab89436817dba8717e56d260d7729f7b9ffd0ceccee351b1fad871a13cec6215a06c1735dd3cf5e278fc7466583db647467c3da1786da
EBUILD dsdp-5.8-r4.ebuild 2348 BLAKE2B 11a061fd889bd1ccb98490ec5b26dd0c3a9ce0b5b280380602100c0f1054c18fe06fd9c38be617937354deca4cca969f3aaba8fb6ca48cf2a60352a5c1b6e201 SHA512 de7b3a461173bc55c3011960287c218b7ad3de2d921e1d3acbc267a47197c20ec19f2092d9ad855ae63cb76b975e0adda9000c6123233bd2988763f8da8ce4a4
MISC metadata.xml 1247 BLAKE2B a16963bce23be7c86668f69d4f7da2eddbafa59aca0f7c02624dde51a87a79f8cab972509ff63aee66cde41767f91181e0f67310fc2e08f52eba8cf31aebf102 SHA512 357a53f66ebafc58279b6af27d833ca154805bcf626c7d719c3041ed701609b509ee35e393e7218fe54e97aef6873b4484367daed861f6a17cb563d9a4dcaad3
diff --git a/sci-libs/dsdp/dsdp-5.8-r3.ebuild b/sci-libs/dsdp/dsdp-5.8-r3.ebuild
deleted file mode 100644
index 6ddc6b9b3640..000000000000
--- a/sci-libs/dsdp/dsdp-5.8-r3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib toolchain-funcs versionator
-
-MY_P="${PN^^}${PV}"
-
-DESCRIPTION="Software for interior-point for semidefinite programming"
-HOMEPAGE="https://www.mcs.anl.gov/hs/software/DSDP/"
-SRC_URI="https://www.mcs.anl.gov/hs/software/DSDP/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="doc examples"
-
-RDEPEND="virtual/lapack"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-readsdpa.patch
- "${FILESDIR}"/${P}-malloc.patch
- "${FILESDIR}"/${P}-gold.patch
-)
-
-make_shared_lib() {
- local soname=$(basename "${1%.a}")$(get_libname $(get_major_version))
- local cflags=()
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- cflags+=(
- "-Wl,-install_name"
- "-Wl,${EPREFIX}/usr/$(get_libdir)/${soname}"
- )
- else
- cflags+=(
- "-shared" "-Wl,-soname=${soname}"
- "-Wl,--whole-archive" "${1}" "-Wl,--no-whole-archive"
- )
- fi
- einfo "Making ${soname}"
- ${2:-$(tc-getCC)} ${LDFLAGS} \
- "${cflags[@]}" \
- -o $(dirname "${1}")/"${soname}" \
- -lm $($(tc-getPKG_CONFIG) --libs blas lapack) || return 1
-}
-
-src_prepare() {
- default
- # to do proper parallel compilation
- while IFS="" read -d $'\0' -r file; do
- sed -i -e 's:make :$(MAKE) :g' "${file}" || die
- done < <(find . -name Makefile -print0)
- sed -i -e 's:make clean:$(MAKE) clean:g' make.include || die
- sed -i \
- -e "s|#\(DSDPROOT[[:space:]]*=\).*|\1${S}|" \
- -e "s|\(CC[[:space:]]*=\).*|\1$(tc-getCC)|" \
- -e "s|\(OPTFLAGS[[:space:]]*=\).*|\1${CFLAGS}|" \
- -e "s|\(CLINKER[[:space:]]*=\).*|\1 \${CC} ${LDFLAGS}|" \
- -e "s|\(LAPACKBLAS[[:space:]]*=\).*|\1 $($(tc-getPKG_CONFIG) --libs blas lapack)|" \
- -e "s|\(^ARCH[[:space:]]*=\).*|\1$(tc-getAR) cr|" \
- -e "s|\(^RANLIB[[:space:]]*=\).*|\1$(tc-getRANLIB)|" \
- make.include || die
-}
-
-src_compile() {
- emake OPTFLAGS="${CFLAGS} -fPIC" dsdplibrary
- make_shared_lib lib/lib${PN}.a || die "doing shared lib failed"
-}
-
-src_test() {
- emake -j1 example test
-}
-
-src_install() {
- dolib.so lib/lib${PN}$(get_libname $(get_major_version))
- dosym lib${PN}$(get_libname $(get_major_version)) \
- /usr/$(get_libdir)/lib${PN}$(get_libname)
-
- doheader include/*.h src/sdp/*.h
-
- use doc && DOCS+=( docs/*.pdf )
- use examples && DOCS+=( examples/. )
- einstalldocs
-}