summaryrefslogtreecommitdiff
path: root/sci-libs/dealii/dealii-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/dealii/dealii-9999.ebuild')
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index f95f48acaaac..2e1f4a47b3ba 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -8,7 +8,7 @@ EAPI=7
# any of these modules:
CMAKE_REMOVE_MODULES_LIST=""
-inherit cmake multilib
+inherit cmake flag-o-matic multilib
DESCRIPTION="Solving partial differential equations with the finite element method"
HOMEPAGE="https://www.dealii.org/"
@@ -40,11 +40,6 @@ REQUIRED_USE="
slepc? ( petsc )
trilinos? ( mpi )"
-# FIXME: The opencascade-7.5.1 ebuild uses a new file system layout where
-# the names of the correct include and library directories are not easily
-# accessible. Just fix the version for the time being.
-CAS_VERSION=7.5.3
-
RDEPEND="dev-libs/boost:=
app-arch/bzip2
sys-libs/zlib
@@ -65,7 +60,7 @@ RDEPEND="dev-libs/boost:=
)
mpi? ( virtual/mpi[cxx] )
muparser? ( dev-cpp/muParser )
- opencascade? ( ~sci-libs/opencascade-${CAS_VERSION}:= )
+ opencascade? ( >=sci-libs/opencascade-7.6.0:= )
p4est? ( sci-libs/p4est[mpi] )
petsc? ( sci-mathematics/petsc[mpi=] )
scalapack? ( sci-libs/scalapack )
@@ -129,21 +124,23 @@ src_configure() {
-DDEAL_II_WITH_TRILINOS="$(usex trilinos)"
)
- # Do a little dance for purely cosmetic "QA" reasons.
+ # Do a little dance for purely cosmetic QA reasons.
use opencascade && mycmakeargs+=(
- -DOPENCASCADE_DIR="${CASROOT}/$(get_libdir)/opencascade-${CAS_VERSION}"
- -DOPENCASCADE_INCLUDE_DIR="${CASROOT}/include/opencascade-${CAS_VERSION}"
+ -DOPENCASCADE_DIR="${CASROOT}/$(get_libdir)/opencascade"
)
- # Do a little dance for purely cosmetic "QA" reasons. The build system
+ # Do a little dance for purely cosmetic QA reasons. The build system
# does query for the highest instruction set first and skips the other
# variables if a "higher" variant is set
if use cpu_flags_x86_avx512f; then
mycmakeargs+=( -DDEAL_II_HAVE_AVX512=yes )
+ append-cxxflags "-mavx512f"
elif use cpu_flags_x86_avx; then
mycmakeargs+=( -DDEAL_II_HAVE_AVX=yes )
+ append-cxxflags "-mavx2"
elif use cpu_flags_x86_avx; then
mycmakeargs+=( -DDEAL_II_HAVE_SSE2=yes )
+ append-cxxflags "-msse2"
fi
cmake_src_configure