summaryrefslogtreecommitdiff
path: root/sci-libs/cxsparse/cxsparse-2.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cxsparse/cxsparse-2.2.6.ebuild')
-rw-r--r--sci-libs/cxsparse/cxsparse-2.2.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/cxsparse/cxsparse-2.2.6.ebuild b/sci-libs/cxsparse/cxsparse-2.2.6.ebuild
new file mode 100644
index 000000000000..877ce88cdf42
--- /dev/null
+++ b/sci-libs/cxsparse/cxsparse-2.2.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=CXSparse
+
+DESCRIPTION="Extended sparse matrix package"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="sci-libs/ufconfig"
+RDEPEND=""
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${PN}-2.2.2-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"