summaryrefslogtreecommitdiff
path: root/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch')
-rw-r--r--sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch b/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
new file mode 100644
index 000000000000..dd93b8af743a
--- /dev/null
+++ b/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -280,8 +280,14 @@ rocm_package_setup_component(profiler
+ )
+
+ add_subdirectory(library)
+-add_subdirectory(example)
+-add_subdirectory(test)
++option(BUILD_EXAMPLES "Build examples" OFF)
++if(BUILD_EXAMPLES)
++ add_subdirectory(example)
++endif()
++option(BUILD_TESTS "Build binaries for tests" OFF)
++if(BUILD_TESTS)
++ add_subdirectory(test)
++endif()
+ add_subdirectory(profiler)
+
+ #Create an interface target for the include only files and call it "composablekernels"