summaryrefslogtreecommitdiff
path: root/sci-libs/colamd/colamd-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/colamd/colamd-3.0.3.ebuild')
-rw-r--r--sci-libs/colamd/colamd-3.0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/colamd/colamd-3.0.3.ebuild b/sci-libs/colamd/colamd-3.0.3.ebuild
new file mode 100644
index 000000000000..b0a4af5bedc1
--- /dev/null
+++ b/sci-libs/colamd/colamd-3.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DDEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Run demo files
+ ./colamd_example > colamd_example.out || die "failed to run test colamd_example"
+ diff "${S}"/Demo/colamd_example.out colamd_example.out || die "failed testing colamd_example"
+ ./colamd_l_example > colamd_l_example.out || die "failed to run test colamd_l_example"
+ diff "${S}"/Demo/colamd_l_example.out colamd_l_example.out || die "failed testing colamd_l_example"
+}