summaryrefslogtreecommitdiff
path: root/sci-libs/cln/cln-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cln/cln-1.3.3.ebuild')
-rw-r--r--sci-libs/cln/cln-1.3.3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-libs/cln/cln-1.3.3.ebuild b/sci-libs/cln/cln-1.3.3.ebuild
index 8b641d2d4f4d..9687c7bb01a1 100644
--- a/sci-libs/cln/cln-1.3.3.ebuild
+++ b/sci-libs/cln/cln-1.3.3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
RDEPEND="dev-libs/gmp:0="
DEPEND="${RDEPEND}
@@ -35,6 +35,11 @@ src_prepare() {
autotools-utils_src_prepare
}
+src_configure() {
+ local myeconfargs=( --disable-static )
+ autotools-utils_src_configure
+}
+
src_compile() {
autotools-utils_src_compile
if use doc; then
@@ -53,4 +58,6 @@ src_install() {
insinto /usr/share/doc/${PF}/examples
doins examples/*.cc
fi
+
+ find "${ED}" -name '*.la' -delete || die
}