summaryrefslogtreecommitdiff
path: root/sci-libs/cantera/cantera-3.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cantera/cantera-3.0.0-r1.ebuild')
-rw-r--r--sci-libs/cantera/cantera-3.0.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-libs/cantera/cantera-3.0.0-r1.ebuild b/sci-libs/cantera/cantera-3.0.0-r1.ebuild
index 9f0de3263452..c6b3ec2711e1 100644
--- a/sci-libs/cantera/cantera-3.0.0-r1.ebuild
+++ b/sci-libs/cantera/cantera-3.0.0-r1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
+inherit flag-o-matic fortran-2 python-single-r1 scons-utils toolchain-funcs
DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
HOMEPAGE="https://www.cantera.org"
@@ -78,6 +78,10 @@ pkg_setup() {
## Full list of configuration options of Cantera is presented here:
## http://cantera.org/docs/sphinx/html/compiling/config-options.html
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://github.com/Cantera/cantera/issues/1783
+ filter-lto
+
scons_vars=(
AR="$(tc-getAR)"
CC="$(tc-getCC)"