summaryrefslogtreecommitdiff
path: root/sci-libs/arpack/arpack-3.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arpack/arpack-3.5.0.ebuild')
-rw-r--r--sci-libs/arpack/arpack-3.5.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-libs/arpack/arpack-3.5.0.ebuild b/sci-libs/arpack/arpack-3.5.0.ebuild
index 91539e12556e..097be6e89f8f 100644
--- a/sci-libs/arpack/arpack-3.5.0.ebuild
+++ b/sci-libs/arpack/arpack-3.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools eutils fortran-2 toolchain-funcs
+inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
@@ -33,8 +33,9 @@ src_prepare() {
}
src_configure() {
+ append-fflags -fallow-argument-mismatch
econf \
- --disable-static
+ --disable-static \
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
$(use_enable mpi)
@@ -47,11 +48,11 @@ src_install() {
newdoc DOCUMENTS/README README.doc
use doc && dodoc "${WORKDIR}"/*.ps
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r EXAMPLES
+ docinto /usr/share/doc/${PF}
+ dodoc -r EXAMPLES
if use mpi; then
- insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
- doins -r PARPACK/EXAMPLES/MPI
+ docinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ dodoc -r PARPACK/EXAMPLES/MPI
fi
fi
}