summaryrefslogtreecommitdiff
path: root/sci-libs/adolc/adolc-2.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/adolc/adolc-2.7.2.ebuild')
-rw-r--r--sci-libs/adolc/adolc-2.7.2.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-libs/adolc/adolc-2.7.2.ebuild b/sci-libs/adolc/adolc-2.7.2.ebuild
index dc6d88c74f35..52d83ebbf38a 100644
--- a/sci-libs/adolc/adolc-2.7.2.ebuild
+++ b/sci-libs/adolc/adolc-2.7.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs eutils
+inherit autotools toolchain-funcs
DESCRIPTION="Automatic differentiation system for C/C++"
HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
@@ -11,11 +11,9 @@ HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
- SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/ADOL-C-releases-${PV}"
fi
@@ -33,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
"${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
"${FILESDIR}"/${PN}-2.6.2-dash.patch
+ "${FILESDIR}"/${P}-swig-python-configure.patch
)
src_prepare() {
@@ -41,9 +40,14 @@ src_prepare() {
}
src_configure() {
+ # Disabling Python for now because swig build
+ # needs work. Revisit with >=2.7.3.
+ # https://bugs.gentoo.org/730750
+ # https://github.com/coin-or/ADOL-C/issues/20
econf \
--enable-advanced-branching \
--enable-atrig-erf \
+ --disable-python \
$(use_enable mpi ampi) \
$(use_enable sparse) \
$(use_enable static-libs static) \
@@ -52,6 +56,8 @@ src_configure() {
}
src_test() {
+ # 'check' target is unrelated to checking lib works
+ # ('check' is more like distcheck)
emake test
}