summaryrefslogtreecommitdiff
path: root/sci-libs/NNPACK/NNPACK-2020.12.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/NNPACK/NNPACK-2020.12.22.ebuild')
-rw-r--r--sci-libs/NNPACK/NNPACK-2020.12.22.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/NNPACK/NNPACK-2020.12.22.ebuild b/sci-libs/NNPACK/NNPACK-2020.12.22.ebuild
index 986c10b7a447..f8a9435a32cb 100644
--- a/sci-libs/NNPACK/NNPACK-2020.12.22.ebuild
+++ b/sci-libs/NNPACK/NNPACK-2020.12.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,6 +44,11 @@ python_check_deps() {
python_has_version "dev-python/PeachPy[${PYTHON_USEDEP}]"
}
+src_prepare() {
+ sed -i -e "/-O/d" CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DNNPACK_BUILD_TESTS=$(usex test ON OFF)