summaryrefslogtreecommitdiff
path: root/sci-geosciences/qgis/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-3.16.0-cmake-lib-suffix.patch (renamed from sci-geosciences/qgis/files/qgis-3.10.0-cmake-lib-suffix.patch)2
-rw-r--r--sci-geosciences/qgis/files/qgis-3.16.1-default-qmldir.patch26
-rw-r--r--sci-geosciences/qgis/files/qgis-3.16.1-featuresummary.patch32
-rw-r--r--sci-geosciences/qgis/files/qgis-3.16.1-find-qt5linguisttools.patch27
4 files changed, 86 insertions, 1 deletions
diff --git a/sci-geosciences/qgis/files/qgis-3.10.0-cmake-lib-suffix.patch b/sci-geosciences/qgis/files/qgis-3.16.0-cmake-lib-suffix.patch
index 472b8aa466ce..1edba1f0e747 100644
--- a/sci-geosciences/qgis/files/qgis-3.10.0-cmake-lib-suffix.patch
+++ b/sci-geosciences/qgis/files/qgis-3.16.0-cmake-lib-suffix.patch
@@ -4,7 +4,7 @@ diff -Naru a/cmake/PyQtMacros.cmake b/cmake/PyQtMacros.cmake
@@ -36,7 +36,7 @@
ELSE(CMAKE_HOST_WIN32)
# TODO osx
- SET(PYUIC_WRAPPER "${CMAKE_SOURCE_DIR}/scripts/pyuic-wrapper.sh")
+ SET(PYUIC_WRAPPER "${CMAKE_SOURCE_DIR}/scripts/pyuic_wrapper.sh")
- SET(PYUIC_WRAPPER_PATH "${QGIS_OUTPUT_DIRECTORY}/lib")
+ SET(PYUIC_WRAPPER_PATH "${QGIS_OUTPUT_DIRECTORY}/lib${LIB_SUFFIX}")
ENDIF(CMAKE_HOST_WIN32)
diff --git a/sci-geosciences/qgis/files/qgis-3.16.1-default-qmldir.patch b/sci-geosciences/qgis/files/qgis-3.16.1-default-qmldir.patch
new file mode 100644
index 000000000000..9a57d45984e2
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.16.1-default-qmldir.patch
@@ -0,0 +1,26 @@
+From ad432e066fcc3d985fb5a451ad128cdf35c1dad9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 20 Nov 2020 20:41:36 +0100
+Subject: [PATCH] cmake: Fix DEFAULT_QML_DIR path to comply with LFS layout
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 61b4c863d0..e7d0bdc8d3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -750,7 +750,7 @@ if (WITH_CORE)
+ set (DEFAULT_LIBEXEC_SUBDIR lib${LIB_SUFFIX}/qgis)
+ set (DEFAULT_PLUGIN_SUBDIR lib${LIB_SUFFIX}/qgis/plugins)
+ set (DEFAULT_INCLUDE_SUBDIR include/qgis)
+- set (DEFAULT_QML_SUBDIR qml)
++ set (DEFAULT_QML_SUBDIR ${DEFAULT_DATA_SUBDIR}/qml)
+
+ set (DEFAULT_SERVER_MODULE_SUBDIR ${DEFAULT_LIBEXEC_SUBDIR}/server)
+ endif()
+--
+2.29.2
+
diff --git a/sci-geosciences/qgis/files/qgis-3.16.1-featuresummary.patch b/sci-geosciences/qgis/files/qgis-3.16.1-featuresummary.patch
new file mode 100644
index 000000000000..b1098175647c
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.16.1-featuresummary.patch
@@ -0,0 +1,32 @@
+From f0fd6e80ad034cf7c49f4ba3708819424b6857b2 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 20 Nov 2020 20:41:06 +0100
+Subject: [PATCH] cmake: Use FeatureSummary
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f581b2c889..61b4c863d0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -111,6 +111,8 @@ if (FORCE_STATIC_PROVIDERS)
+ set (HAVE_STATIC_PROVIDERS TRUE)
+ endif()
+
++include(FeatureSummary)
++
+ # in generated makefiles use relative paths so the project dir is moveable
+ # Note commented out since it cause problems but it would be nice to resolve these and enable
+ #
+@@ -1035,3 +1037,5 @@ endif()
+ if (UNIX AND NOT APPLE)
+ add_subdirectory(linux)
+ endif()
++
++FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--
+2.29.2
+
diff --git a/sci-geosciences/qgis/files/qgis-3.16.1-find-qt5linguisttools.patch b/sci-geosciences/qgis/files/qgis-3.16.1-find-qt5linguisttools.patch
new file mode 100644
index 000000000000..01f602694395
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.16.1-find-qt5linguisttools.patch
@@ -0,0 +1,27 @@
+From db2fee6c199a34507e5742b2360d594a5bf67b18 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 23 Nov 2020 22:04:50 +0100
+Subject: [PATCH] Fix Qt5LinguistTools detection/lrelease binary location
+
+Correctly find the Qt5 module that provides the path to Qt5-based lrelease.
+Available since >= Qt-5.3.1 which is well below the current minimum for QGIS.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ i18n/CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/i18n/CMakeLists.txt b/i18n/CMakeLists.txt
+index a836e5cae5..7d7f79da89 100644
+--- a/i18n/CMakeLists.txt
++++ b/i18n/CMakeLists.txt
+@@ -1,4 +1,5 @@
+-find_program(QT_LRELEASE_EXECUTABLE NAMES lrelease-qt5 lrelease)
++find_package(Qt5LinguistTools REQUIRED)
++set(QT_LRELEASE_EXECUTABLE Qt5::lrelease)
+
+ macro(ADD_TRANSLATION_FILES _sources )
+ foreach (_current_FILE ${ARGN})
+--
+2.29.2
+