summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd/gpsd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-9999.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 9bf817942858..53bc8d53f9fd 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
SCONS_MIN_VERSION="2.3.0"
inherit distutils-r1 scons-utils systemd toolchain-funcs udev
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
inherit git-r3
else
@@ -21,7 +21,7 @@ DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping c
HOMEPAGE="https://gpsd.gitlab.io/gpsd/"
LICENSE="BSD"
-SLOT="0/29"
+SLOT="0/30"
GPSD_PROTOCOLS=(
aivdm ashtech earthmate evermore fury fv18 garmin garmintxt geostar
@@ -30,13 +30,15 @@ GPSD_PROTOCOLS=(
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp +python qt5 +shm +sockets static systemd test udev usb X"
-REQUIRED_USE="X? ( python )
+REQUIRED_USE="
+ X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
gpsd_protocols_isync? ( gpsd_protocols_ublox )
gpsd_protocols_ublox? ( python )
gpsd_protocols_greis? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
- qt5? ( cxx )"
+ qt5? ( cxx )
+"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -208,13 +210,13 @@ python_test() {
}
src_install() {
- DESTDIR="${D}" escons install "${scons_opts[@]}" $(usex udev udev-install '')
+ DESTDIR="${D}" escons install "${scons_opts[@]}" $(usev udev udev-install)
newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
newinitd "${FILESDIR}"/gpsd.init-2 gpsd
# Cleanup bad alt copy due to Scons
- rm -rf "${D}"/python-discard/gps*
+ rm -rf "${D}"/python-discard/gps*
find "${D}"/python-discard/ -type d -delete
# Install correct multi-python copy
pushd "${P}" || die