summaryrefslogtreecommitdiff
path: root/sci-geosciences/geopy
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/geopy')
-rw-r--r--sci-geosciences/geopy/Manifest3
-rw-r--r--sci-geosciences/geopy/geopy-2.2.0.ebuild21
-rw-r--r--sci-geosciences/geopy/metadata.xml17
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/Manifest b/sci-geosciences/geopy/Manifest
new file mode 100644
index 000000000000..f546cc388540
--- /dev/null
+++ b/sci-geosciences/geopy/Manifest
@@ -0,0 +1,3 @@
+DIST geopy-2.2.0.tar.gz 289811 BLAKE2B f876a867a19e5178eba1fa6b7389159e820fc6a9c9a6ac4beb807e2b1b121612a526b5f7290d5fd6db3e259cbd03a86695775d4cad39662126d5f5b7194b19bd SHA512 78b6c2e4726dd50ad97e3425a0459b4611eed54c06c16a2b397db9c3fd9878d76f9eba26ce353908315fea469a76b4044401f5ba37aab3752e9649fd35db16cd
+EBUILD geopy-2.2.0.ebuild 560 BLAKE2B 8f40ec9dfa51a46ddc2ba97fd879d2993c9824554701f8eb069eaf88e450f7975749eea7b6bfa405ae663694f06c05804c240a68fb5e41c318bb0dc172983b2f SHA512 7cf2a45ea650387dd25cfc5c840b1a7c744e99df03707a4fbb3f0e992bc7aa583c6dbb6f38eebbe3f86d2d770c9aff93ba11f2a796a73130463b07a532adaf21
+MISC metadata.xml 633 BLAKE2B 30a6c40ee0d395957994d9ec99cbad8ffda1cc62d44460890b2c6f789f11b9b051f6ea7740923cfe7a3663be96f2a126578d9f19c35ff4d5315537857c51a33e SHA512 51c0db7e58e35a1db28ede06b3fca9a244b4b13d3f536e500008da8acad96fe605e0588664974a51dd1e749c85d9fe0e6c81f9e4d923635da65d852e952ddd4f
diff --git a/sci-geosciences/geopy/geopy-2.2.0.ebuild b/sci-geosciences/geopy/geopy-2.2.0.ebuild
new file mode 100644
index 000000000000..0eca56b94d75
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="https://github.com/geopy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND=">=sci-geosciences/GeographicLib-1.51-r1[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
diff --git a/sci-geosciences/geopy/metadata.xml b/sci-geosciences/geopy/metadata.xml
new file mode 100644
index 000000000000..17a8d5bb1069
--- /dev/null
+++ b/sci-geosciences/geopy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ geopy is a Python client for several popular geocoding web services.
+ geopy makes it easy for Python developers to locate the coordinates
+ of addresses, cities, countries, and landmarks across the globe using
+ third-party geocoders and other data sources.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">geopy/geopy</remote-id>
+ </upstream>
+</pkgmetadata>