summaryrefslogtreecommitdiff
path: root/sci-geosciences/congen/congen-1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/congen/congen-1.7.ebuild')
-rw-r--r--sci-geosciences/congen/congen-1.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-geosciences/congen/congen-1.7.ebuild b/sci-geosciences/congen/congen-1.7.ebuild
new file mode 100644
index 000000000000..2059b79c6641
--- /dev/null
+++ b/sci-geosciences/congen/congen-1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Calculate speeds, equilibrium arguments, node factors of tidal constituents"
+HOMEPAGE="http://www.flaterco.com/xtide/files.html"
+SRC_URI="https://flaterco.com/files/xtide/${P}-r2.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-geosciences/libtcd-2.2.3"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}