summaryrefslogtreecommitdiff
path: root/sci-electronics/xoscope/xoscope-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/xoscope/xoscope-2.3.ebuild')
-rw-r--r--sci-electronics/xoscope/xoscope-2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-electronics/xoscope/xoscope-2.3.ebuild b/sci-electronics/xoscope/xoscope-2.3.ebuild
new file mode 100644
index 000000000000..7dee2f34fbac
--- /dev/null
+++ b/sci-electronics/xoscope/xoscope-2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Soundcard Oscilloscope for X"
+HOMEPAGE="http://xoscope.sourceforge.net"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/alsa-lib
+ sci-libs/fftw:3.0=
+ virtual/man
+ x11-libs/gtk+:3
+ >=x11-libs/gtkdatabox-1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~!SND_PCM_OSS"
+ERROR_SND_PCM_OSS="CONFIG_SND_PCM_OSS is needed to support sound card input via /dev/dsp"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2-man_no_-Tutf8.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}