summaryrefslogtreecommitdiff
path: root/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild')
-rw-r--r--sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild b/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
index 9bac71de0ad4..9e14ed9013bb 100644
--- a/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
+++ b/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
COMMIT=b5bd459dd5c2a180a9a3e5a706ed5039159d7286
-inherit cmake-utils vcs-snapshot
+inherit cmake
DESCRIPTION="Multi-platform open source software oscilloscope based on Qt"
HOMEPAGE="https://github.com/stephanemagnenat/osqoop https://github.com/sandsmark/osqoop"
# sandsmark/osqoop: PR-branch on top of last commit in stephanemagnenat/osqoop (17-01-31)
SRC_URI="https://github.com/sandsmark/osqoop/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
@@ -25,3 +26,8 @@ RDEPEND="
virtual/libusb:0
x11-libs/libXtst"
DEPEND="${RDEPEND}"
+
+# downstream fix for BUILD_SHARED_LIBS=ON default
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-add_library-static.patch
+)