summaryrefslogtreecommitdiff
path: root/sci-electronics/librepcb/librepcb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/librepcb/librepcb-9999.ebuild')
-rw-r--r--sci-electronics/librepcb/librepcb-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/librepcb/librepcb-9999.ebuild b/sci-electronics/librepcb/librepcb-9999.ebuild
new file mode 100644
index 000000000000..f33d53c8b45f
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils git-r3
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="http://librepcb.org/"
+EGIT_REPO_URI="https://github.com/LibrePCB/LibrePCB.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 -r PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}