summaryrefslogtreecommitdiff
path: root/sci-electronics/klayout/klayout-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/klayout/klayout-9999.ebuild')
-rw-r--r--sci-electronics/klayout/klayout-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sci-electronics/klayout/klayout-9999.ebuild b/sci-electronics/klayout/klayout-9999.ebuild
index 127d36ffb70f..30250478884e 100644
--- a/sci-electronics/klayout/klayout-9999.ebuild
+++ b/sci-electronics/klayout/klayout-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RUBY_OPTIONAL=no
USE_RUBY="ruby25"
# note: define maximally ONE implementation here
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit toolchain-funcs python-single-r1 ruby-ng
@@ -78,7 +78,13 @@ each_ruby_install() {
cd "${T}/bin" || die
dodir "/usr/$(get_libdir)/klayout"
- mv lib* "${ED}/usr/$(get_libdir)/klayout/" || die
+ mv lib* lay_plugins db_plugins "${ED}/usr/$(get_libdir)/klayout/" || die
+
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+ mv pymod/* "${D}/$(python_get_sitedir)/" || die
+ rmdir pymod || die
dobin *
+
+ python_optimize
}