summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca')
-rw-r--r--sci-chemistry/votca/Manifest4
-rw-r--r--sci-chemistry/votca/metadata.xml18
-rw-r--r--sci-chemistry/votca/votca-2022_rc2.ebuild70
-rw-r--r--sci-chemistry/votca/votca-9999.ebuild70
4 files changed, 162 insertions, 0 deletions
diff --git a/sci-chemistry/votca/Manifest b/sci-chemistry/votca/Manifest
new file mode 100644
index 000000000000..b755470d6d3f
--- /dev/null
+++ b/sci-chemistry/votca/Manifest
@@ -0,0 +1,4 @@
+DIST votca-2022_rc2.tar.gz 61692061 BLAKE2B 9fdf016267ff6657bfbbd51c79c2c38cb7064635d26e80b905eeeb8326ca1780f7a9c711802491f3ec7a216dbd53b86fe08da2c969a6a10db110168a02ac0d0f SHA512 3bfd108df7499c21ad290955672ab042b9a11b7a868f0eb49fdbd94365e35ed7ffc8b8b44c9b7dd74b7504b8fd30cc6bacfed443068f2bb3702e272aad26c961
+EBUILD votca-2022_rc2.ebuild 1599 BLAKE2B 709252689e526e83d5b9f0933e44d7b83b6d2e02fd3cbae0938630e87c99a83ac2179ccc06d2d2843f7fca039305f6aff4793357ea44ef2f8db9ff2edee87f90 SHA512 9b41346126363598de2174c9e06a4c7550e82dc4ec22f2fcc0a6b8948731831ae871a2b30988dfcd5d3c5ebdd1e6a377946374bc2d3a2b25c6c3a7732b04ac71
+EBUILD votca-9999.ebuild 1599 BLAKE2B 709252689e526e83d5b9f0933e44d7b83b6d2e02fd3cbae0938630e87c99a83ac2179ccc06d2d2843f7fca039305f6aff4793357ea44ef2f8db9ff2edee87f90 SHA512 9b41346126363598de2174c9e06a4c7550e82dc4ec22f2fcc0a6b8948731831ae871a2b30988dfcd5d3c5ebdd1e6a377946374bc2d3a2b25c6c3a7732b04ac71
+MISC metadata.xml 579 BLAKE2B fc22a14bfa99c926b2c5b2071a10b6dd78baab670551c817c4c4f2e5e6a2e13c5fa216fe7a2aa455f15fbf1c8ae488a06b99960830a2d4fb6a82a6a0a277e233 SHA512 89a2c88dc5dc5e06ccd4e1830caa58e0d74f93e1742f4658ed27b6f41be3bd6924da47dc70cd7fcdce9837ceac4012dfeca39e8bf19d0451f044568d00743539
diff --git a/sci-chemistry/votca/metadata.xml b/sci-chemistry/votca/metadata.xml
new file mode 100644
index 000000000000..137114c8f259
--- /dev/null
+++ b/sci-chemistry/votca/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <use>
+ <flag name="gromacs">Add support for gromacs file formats through <pkg>sci-chemistry/gromacs</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">votca/votca</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/votca/votca-2022_rc2.ebuild b/sci-chemistry/votca/votca-2022_rc2.ebuild
new file mode 100644
index 000000000000..6a1ae090460b
--- /dev/null
+++ b/sci-chemistry/votca/votca-2022_rc2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 cmake
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/votca/votca.git"
+else
+ if [[ ${PV} = *_rc[1-9] ]]; then
+ MY_PV="${PV%%_rc*}-rc.${PV##*_rc}"
+ else
+ MY_PV="${PV}"
+ fi
+ SRC_URI="https://github.com/votca/votca/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ S="${WORKDIR}/votca-${MY_PV}"
+fi
+
+DESCRIPTION="Versatile Object-oriented Toolkit for Coarse-graining Applications"
+HOMEPAGE="https://www.votca.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+gromacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !sci-libs/votca-tools
+ !sci-chemistry/votca-csg
+ !sci-chemistry/votca-xtp
+ app-shells/bash:*
+ >=dev-cpp/eigen-3.3
+ dev-libs/boost:=
+ dev-libs/expat
+ sci-libs/fftw:3.0=
+ dev-lang/perl
+ gromacs? ( sci-chemistry/gromacs:= )
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ sci-libs/libint:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_GROMACS=$(usex !gromacs)
+ -DBUILD_CSGAPPS=ON
+ -DINSTALL_RC_FILES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_MKL=ON
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
+ einfo "https://doi.org/10.1021/acs.jctc.8b00617"
+ einfo
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "https://dx.doi.org/10.1021/ct900369w"
+ einfo
+}
diff --git a/sci-chemistry/votca/votca-9999.ebuild b/sci-chemistry/votca/votca-9999.ebuild
new file mode 100644
index 000000000000..6a1ae090460b
--- /dev/null
+++ b/sci-chemistry/votca/votca-9999.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 cmake
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/votca/votca.git"
+else
+ if [[ ${PV} = *_rc[1-9] ]]; then
+ MY_PV="${PV%%_rc*}-rc.${PV##*_rc}"
+ else
+ MY_PV="${PV}"
+ fi
+ SRC_URI="https://github.com/votca/votca/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ S="${WORKDIR}/votca-${MY_PV}"
+fi
+
+DESCRIPTION="Versatile Object-oriented Toolkit for Coarse-graining Applications"
+HOMEPAGE="https://www.votca.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+gromacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !sci-libs/votca-tools
+ !sci-chemistry/votca-csg
+ !sci-chemistry/votca-xtp
+ app-shells/bash:*
+ >=dev-cpp/eigen-3.3
+ dev-libs/boost:=
+ dev-libs/expat
+ sci-libs/fftw:3.0=
+ dev-lang/perl
+ gromacs? ( sci-chemistry/gromacs:= )
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ sci-libs/libint:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_GROMACS=$(usex !gromacs)
+ -DBUILD_CSGAPPS=ON
+ -DINSTALL_RC_FILES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_MKL=ON
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
+ einfo "https://doi.org/10.1021/acs.jctc.8b00617"
+ einfo
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "https://dx.doi.org/10.1021/ct900369w"
+ einfo
+}