summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-csg/votca-csg-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-9999.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 7aad54413e78..0e02baa215a8 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
@@ -37,12 +37,6 @@ RDEPEND="
app-shells/bash:*"
DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-latexextra
- virtual/latex-base
- dev-tex/pgf
- )
>=app-text/txt2tags-2.5
virtual/pkgconfig"
@@ -73,15 +67,13 @@ src_configure() {
src_install() {
cmake-utils_src_install
- newbashcomp scripts/csg-completion.bash csg_call
+ newbashcomp "${ED}"/usr/share/votca/rc/csg-completion.bash csg_call
for i in "${ED}"/usr/bin/csg_*; do
[[ ${i} = *csg_call ]] && continue
bashcomp_alias csg_call "${i##*/}"
done
if use doc; then
[[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
- cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
- dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
fi
if use examples; then
insinto "/usr/share/doc/${PF}/tutorials"