summaryrefslogtreecommitdiff
path: root/sci-chemistry/suitename/suitename-0.3.070628.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/suitename/suitename-0.3.070628.ebuild')
-rw-r--r--sci-chemistry/suitename/suitename-0.3.070628.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sci-chemistry/suitename/suitename-0.3.070628.ebuild b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
index 8441770df5ca..2243ccf61e55 100644
--- a/sci-chemistry/suitename/suitename-0.3.070628.ebuild
+++ b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -11,26 +11,25 @@ DESCRIPTION="The ROC RNA Ontology nomenclature and conformer-list development"
HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+LICENSE="richardson"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="richardson"
-IUSE=""
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_prepare() {
+src_configure() {
tc-export CC
- cp Makefile.linux Makefile || die
- sed \
- -e 's:cc:${CC}:g' \
- -e "s:-o:${LDFLAGS} -o:g" \
- -i Makefile || die
}
src_compile() {
- emake CFLAGS="${CFLAGS}"
+ emake -f Makefile.linux
}
src_install() {
- dobin ${PN}
+ dobin suitename
}