summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol/pymol-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pymol/pymol-3.0.0.ebuild')
-rw-r--r--sci-chemistry/pymol/pymol-3.0.0.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sci-chemistry/pymol/pymol-3.0.0.ebuild b/sci-chemistry/pymol/pymol-3.0.0.ebuild
index 150f7732d930..b6ec9fbef1e3 100644
--- a/sci-chemistry/pymol/pymol-3.0.0.ebuild
+++ b/sci-chemistry/pymol/pymol-3.0.0.ebuild
@@ -26,19 +26,20 @@ IUSE="+netcdf web"
DEPEND="
dev-cpp/msgpack-cxx
dev-libs/mmtf-cpp
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pmw[${PYTHON_USEDEP}]
+ sys-libs/zlib
media-libs/freetype:2
media-libs/glew:0=
media-libs/glm
media-libs/libpng:0=
- media-video/mpeg-tools
- sys-libs/zlib
netcdf? ( sci-libs/netcdf:0= )
"
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
+ media-video/mpeg-tools
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
sci-chemistry/chemical-mime-data
"
@@ -66,6 +67,11 @@ python_prepare_all() {
}
python_configure_all() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/933235
+ # https://github.com/schrodinger/pymol-open-source/issues/395
+ filter-lto
+
use !netcdf && DISTUTILS_ARGS=( --no-vmd-plugins )
}