summaryrefslogtreecommitdiff
path: root/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild')
-rw-r--r--sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild b/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
new file mode 100644
index 000000000000..9f1cae764afb
--- /dev/null
+++ b/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for working with NMR data in Python"
+HOMEPAGE="http://nmrglue.com/"
+SRC_URI="https://github.com/jjhelmus/nmrglue/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-nohyper.patch )
+
+python_test() {
+ nosetests --verbosity=3 || die
+}