summaryrefslogtreecommitdiff
path: root/sci-chemistry/molscript/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/molscript/files')
-rw-r--r--sci-chemistry/molscript/files/2.1.2-ldflags.patch22
-rw-r--r--sci-chemistry/molscript/files/2.1.2-libpng15.patch19
-rw-r--r--sci-chemistry/molscript/files/2.1.2-prll.patch10
-rw-r--r--sci-chemistry/molscript/files/fix-makefile-shared.patch62
-rw-r--r--sci-chemistry/molscript/files/glutbitmap.h32
5 files changed, 0 insertions, 145 deletions
diff --git a/sci-chemistry/molscript/files/2.1.2-ldflags.patch b/sci-chemistry/molscript/files/2.1.2-ldflags.patch
deleted file mode 100644
index 8867bc10a6b5..000000000000
--- a/sci-chemistry/molscript/files/2.1.2-ldflags.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/Makefile.complete b/Makefile.complete
-index 4ad535a..b565266 100644
---- a/Makefile.complete
-+++ b/Makefile.complete
-@@ -91,7 +91,7 @@ clean:
-
- #------------------------------------------------------------
- molscript: $(OBJ) clib/clib.a
-- $(CC) -o molscript $(COPT) $(OBJ) $(YLIB) clib/clib.a \
-+ $(CC) $(LDFLAGS) -o molscript $(COPT) $(OBJ) $(YLIB) clib/clib.a \
- $(GLUTLINK) $(JPEGLINK) $(PNGLINK) $(GIFLINK) $(ZLIBLINK) -lm
-
- molscript.tab.o: molscript.tab.c molscript.tab.h
-@@ -147,7 +147,7 @@ gif_img.o: gif_img.c gif_img.h global.h graphics.h image.h opengl.h
-
- #------------------------------------------------------------
- molauto: molauto.o clib/clib.a
-- $(CC) -o molauto molauto.o clib/clib.a -lm
-+ $(CC) $(LDFLAGS) -o molauto molauto.o clib/clib.a -lm
-
- molauto.o: molauto.c
-
diff --git a/sci-chemistry/molscript/files/2.1.2-libpng15.patch b/sci-chemistry/molscript/files/2.1.2-libpng15.patch
deleted file mode 100644
index 9ed1b85909e8..000000000000
--- a/sci-chemistry/molscript/files/2.1.2-libpng15.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- png_img.c
-+++ png_img.c
-@@ -18,6 +18,7 @@
-
- #include <GL/gl.h>
-
-+#include <zlib.h>
- #include <png.h>
-
- #include "clib/str_utils.h"
-@@ -69,7 +70,7 @@
- info_ptr = png_create_info_struct (png_ptr);
- if (info_ptr == NULL)
- yyerror ("png_img: could not create PNG info structure");
-- if (setjmp (png_ptr->jmpbuf)) yyerror ("png_img: could not setjmp");
-+ if (setjmp (png_jmpbuf(png_ptr))) yyerror ("png_img: could not setjmp");
-
- png_init_io (png_ptr, outfile);
- png_set_compression_level (png_ptr, compression_level);
diff --git a/sci-chemistry/molscript/files/2.1.2-prll.patch b/sci-chemistry/molscript/files/2.1.2-prll.patch
deleted file mode 100644
index e4c972a10533..000000000000
--- a/sci-chemistry/molscript/files/2.1.2-prll.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/Makefile.complete b/Makefile.complete
-index 92ef20a..e3f68e3 100644
---- a/Makefile.complete
-+++ b/Makefile.complete
-@@ -153,4 +153,4 @@ molauto.o: molauto.c
-
- #------------------------------------------------------------
- clib/clib.a:
-- cd clib; make clib.a CFLAGS="-I. $(CFLAGS)" OPENGLCLIBOBJ="$(OPENGLCLIBOBJ)"
-+ $(MAKE) -C clib clib.a CFLAGS="-I. $(CFLAGS)" OPENGLCLIBOBJ="$(OPENGLCLIBOBJ)"
diff --git a/sci-chemistry/molscript/files/fix-makefile-shared.patch b/sci-chemistry/molscript/files/fix-makefile-shared.patch
deleted file mode 100644
index a9947a61a665..000000000000
--- a/sci-chemistry/molscript/files/fix-makefile-shared.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -urN molscript-2.1.2.orig/Makefile.complete molscript-2.1.2/Makefile.complete
---- molscript-2.1.2.orig/Makefile.complete 1998-11-25 01:04:39.000000000 -0800
-+++ molscript-2.1.2/Makefile.complete 2005-11-21 12:28:06.000000000 -0800
-@@ -23,9 +23,9 @@
-
- # OpenGL and GLUT for X (UNIX).
- # Must be modified for Windows 95/NT. <---
--GLUTDIR = $(FREEWAREDIR)/glut
--GLUTLINK = $(GLUTDIR)/lib/glut/libglut.a -lGLU -lGL -lXmu -lXext -lX11
--OPENGLFLAG = -DOPENGL_SUPPORT -I$(GLUTDIR)/include
-+GLUTDIR = $(FREEWAREDIR)
-+GLUTLINK = -lglut -lGLU -lGL -lXmu -lXext -lX11
-+OPENGLFLAG = -DOPENGL_SUPPORT -I$(GLUTDIR)/include/GL
- OPENGLOBJ = opengl.o
- OPENGLCLIBOBJ = ogl_utils.o ogl_body.o ogl_bitmap_character.o
-
-@@ -35,25 +35,25 @@
-
- # JPEG image file format; requires the JPEG library.
- # Comment out these lines if the JPEG library is not available. <---
--JPEGDIR = $(FREEWAREDIR)/jpeg
--JPEGLINK = $(JPEGDIR)/libjpeg.a
--JPEGFLAG = -DJPEG_SUPPORT -I$(JPEGDIR)
-+JPEGDIR = $(FREEWAREDIR)
-+JPEGLINK = -ljpeg
-+JPEGFLAG = -DJPEG_SUPPORT
- JPEGOBJ = jpeg_img.o
-
- # PNG image file format; requires the PNG library and the zlib library.
- # Comment out these lines if the PNG and zlib libraries are not available. <---
--ZLIBDIR = $(FREEWAREDIR)/zlib
--ZLIBLINK = $(ZLIBDIR)/libz.a
--PNGDIR = $(FREEWAREDIR)/libpng
--PNGLINK = $(PNGDIR)/libpng.a
--PNGFLAG = -DPNG_SUPPORT -I$(PNGDIR) -I$(ZLIBDIR)
-+ZLIBDIR = $(FREEWAREDIR)
-+ZLIBLINK = -lz
-+PNGDIR = $(FREEWAREDIR)
-+PNGLINK = -lpng
-+PNGFLAG = -DPNG_SUPPORT
- PNGOBJ = png_img.o
-
- # GIF image file format; requires the gd 1.3 library.
- # Comment out these lines if the gd 1.3 library is not available. <---
--GIFDIR = $(FREEWAREDIR)/gd
--GIFLINK = $(GIFDIR)/libgd.a
--GIFFLAG = -DGIF_SUPPORT -I$(GIFDIR)
-+GIFDIR = $(FREEWAREDIR)
-+GIFLINK = -lgd
-+GIFFLAG = -DGIF_SUPPORT
- GIFOBJ = gif_img.o
-
- # SGI IRIX's C compiler.
-@@ -62,7 +62,7 @@
- COPT = -O1
- # Correctness flags:
- #CCHECK = -ansi -fullwarn -g -DSELECT_DEBUG
--CCHECK = -ansi -fullwarn
-+CCHECK = -ansi
- #CCHECK = -ansi -fullwarn -DNDEBUG
-
- # General cc compile flags.
diff --git a/sci-chemistry/molscript/files/glutbitmap.h b/sci-chemistry/molscript/files/glutbitmap.h
deleted file mode 100644
index 9584bb129daa..000000000000
--- a/sci-chemistry/molscript/files/glutbitmap.h
+++ /dev/null
@@ -1,32 +0,0 @@
-#ifndef __glutbitmap_h__
-#define __glutbitmap_h__
-
-/* Copyright (c) Mark J. Kilgard, 1994, 1998. */
-
-/* This program is freely distributable without licensing fees
- and is provided without guarantee or warrantee expressed or
- implied. This program is -not- in the public domain. */
-
-#define GLUT_NO_LIB_PRAGMA /* Avoid auto library linking when building
- the GLUT library itself. */
-#include <GL/glut.h>
-
-typedef struct {
- const GLsizei width;
- const GLsizei height;
- const GLfloat xorig;
- const GLfloat yorig;
- const GLfloat advance;
- const GLubyte *bitmap;
-} BitmapCharRec, *BitmapCharPtr;
-
-typedef struct {
- const char *name;
- const int num_chars;
- const int first;
- const BitmapCharRec * const *ch;
-} BitmapFontRec, *BitmapFontPtr;
-
-typedef void *GLUTbitmapFont;
-
-#endif /* __glutbitmap_h__ */