summaryrefslogtreecommitdiff
path: root/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild')
-rw-r--r--sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
index f5c9d5179d89..faff5eda6a59 100644
--- a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
+++ b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake python-r1 virtualx
@@ -15,13 +16,13 @@ LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+client doc server test +zeromq"
-RESTRICT="!test? ( test )"
-
REQUIRED_USE="
server? ( client )
test? ( server )
zeromq? ( ${PYTHON_REQUIRED_USE} )
"
+# Some tests still fail
+RESTRICT="test !test? ( test )"
BDEPEND="
doc? ( app-doc/doxygen )
@@ -38,9 +39,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-# Some tests still fail
-RESTRICT="test"
-
src_configure() {
configuration() {
local mycmakeargs=(
@@ -51,7 +49,7 @@ src_configure() {
-DENABLE_TESTING=$(usex test)
-DUSE_ZERO_MQ=$(usex zeromq)
-DINSTALL_LIBRARY_DIR=$(get_libdir)
- )
+ )
use zeromq && \
mycmakeargs+=( "-DZeroMQ_ROOT_DIR=\"${EPREFIX}/usr\"" )