summaryrefslogtreecommitdiff
path: root/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild')
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
index 997dacaa72dd..f1d744000147 100644
--- a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}
distutils_enable_tests --install pytest
+PATCHES=(
+ "${FILESDIR}/${P}-python311.patch"
+)
+
python_prepare_all() {
sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
-i basesetup.py || die