summaryrefslogtreecommitdiff
path: root/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild')
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
deleted file mode 100644
index 75356685592c..000000000000
--- a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
-HOMEPAGE="https://mdtraj.org"
-
-SLOT="0"
-LICENSE="LGPL-2.1+"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/astunparse[${PYTHON_USEDEP}]
- dev-python/astor[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/tables[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter-client[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/scikit-learn[${PYTHON_USEDEP}]
- )
-"
-# <cython-3 for bug #911646
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests --install pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-python311.patch"
-)
-
-python_prepare_all() {
- sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
- -i basesetup.py || die
- distutils-r1_python_prepare_all
-}