summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2022.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2022.4.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.4.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2022.4.ebuild b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
index 8719a5c86554..d0f55aca4bc1 100644
--- a/sci-chemistry/gromacs/gromacs-2022.4.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
@@ -22,9 +22,9 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3
else
SRC_URI="
- http://ftp.gromacs.org/gromacs/${P}.tar.gz
+ https://ftp.gromacs.org/gromacs/${P}.tar.gz
doc? ( https://ftp.gromacs.org/manual/manual-${PV}.pdf )
- test? ( http://ftp.gromacs.org/regressiontests/regressiontests-${PV}.tar.gz )"
+ test? ( https://ftp.gromacs.org/regressiontests/regressiontests-${PV}.tar.gz )"
# since 2022 arm support was dropped (but not arm64)
KEYWORDS="~amd64 -arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
@@ -32,7 +32,7 @@ fi
ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512f cpu_flags_arm_neon"
DESCRIPTION="The ultimate molecular dynamics simulation package"
-HOMEPAGE="http://www.gromacs.org/"
+HOMEPAGE="https://www.gromacs.org/"
# see COPYING for details
# https://repo.or.cz/w/gromacs.git/blob/HEAD:/COPYING
@@ -75,6 +75,7 @@ REQUIRED_USE="
|| ( single-precision double-precision )
doc? ( !build-manual )
cuda? ( single-precision )
+ opencl? ( single-precision )
cuda? ( !opencl )
clang-cuda? ( clang cuda )
mkl? ( !blas !fftw !lapack )
@@ -200,11 +201,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl