summaryrefslogtreecommitdiff
path: root/sci-chemistry/easychem/easychem-0.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/easychem/easychem-0.6-r2.ebuild')
-rw-r--r--sci-chemistry/easychem/easychem-0.6-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-chemistry/easychem/easychem-0.6-r2.ebuild b/sci-chemistry/easychem/easychem-0.6-r2.ebuild
new file mode 100644
index 000000000000..eb2e161f20f4
--- /dev/null
+++ b/sci-chemistry/easychem/easychem-0.6-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Chemical structure drawing program - focused on presentation"
+HOMEPAGE="http://easychem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/easychem/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-gfx/pstoedit
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${PN}-0.6-clang16-fix.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ ln -s Makefile.linux Makefile || die
+ DGS_PATH="${EPREFIX}"/usr/bin DPSTOEDIT_PATH="${EPREFIX}"/usr/bin \
+ C_FLAGS="${CFLAGS}" emake -e
+}
+
+src_install() {
+ dobin easychem
+ dodoc TODO
+}