summaryrefslogtreecommitdiff
path: root/sci-chemistry/cyana/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/cyana/files')
-rw-r--r--sci-chemistry/cyana/files/2.1-exec.patch77
-rw-r--r--sci-chemistry/cyana/files/2.1-expire.patch15
-rw-r--r--sci-chemistry/cyana/files/2.1-typo.patch13
-rw-r--r--sci-chemistry/cyana/files/2.1-xiar.patch16
4 files changed, 0 insertions, 121 deletions
diff --git a/sci-chemistry/cyana/files/2.1-exec.patch b/sci-chemistry/cyana/files/2.1-exec.patch
deleted file mode 100644
index 28cd88d3eee6..000000000000
--- a/sci-chemistry/cyana/files/2.1-exec.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/cyana b/cyana
-index 4f746cf..a7ff060 100755
---- a/cyana
-+++ b/cyana
-@@ -45,16 +45,13 @@ shift `expr $optind - 1`
-
- if [ "$h" ]; then usage=1; fi
- if [ "$usage" ]; then
-- echo "Usage: $prog -hctx parameters ..."
-+ echo "Usage: $prog -hS parameters ..."
- echo
- echo " -h help"
- echo " -c command command to start program (must contain \$exefile)"
- echo " -S run in safe mode, i.e. within one directory"
-- echo " -t system explicit system type"
-- echo " -x display name of executable without executing it"
- exit 2
- fi
--if [ "$c" ]; then cmd="$c"; fi
- sys=$t
- mode=$x
- safe=$S
-@@ -65,23 +62,6 @@ safe=$S
- eval ${PROG}ARG='$*'
- export ${PROG}ARG
-
--
--# ------ Set library name ------
--
--f=$0
--if [ `echo $f | sed 's,^/.*,+,'` != "+" ]; then f=`which $0`; fi
--odir=`pwd`
--while [ "`ls -l $f | awk '{ print substr($1,1,1) }'`" = "l" ]; do
-- l=`ls -l $f | awk '{ i = NF; print $i }'`
-- cd `dirname $f`; cd `dirname $l`; l=`pwd`/`basename $l`
-- f=$l
--done
--cd `dirname $f`
--libdir=`pwd | sed 's,/src/'${prog}'$,,'`
--cd $odir
--eval ${PROG}LIB=$libdir
--export ${PROG}LIB
--
- if [ "$safe" ]; then
- CYANAINIT=initsafe; export CYANAINIT
- fi
-@@ -89,29 +69,4 @@ fi
-
- # ------ Start the program ------
-
--if [ -d $libdir/src/$prog ]; then
-- exe=$libdir/src/$prog/$exe
--else
-- exe=$libdir/$exe
--fi
--if [ "$sys" = "" ]; then
-- sys=`$libdir/etc/identify`
-- files="$exe.$sys* $exe.gnu $exe.*"
--else
-- files=$exe.$sys
--fi
--for exefile in $files; do
-- if [ -x $exefile ]; then
-- if [ "$mode" ]; then
-- echo $exefile; exit 0
-- else
-- if [ "`echo $cmd | grep -c '\$exefile'`" -gt 0 ]; then
-- eval exec $cmd
-- else
-- eval exec $cmd $exefile
-- fi
-- fi
-- fi
--done
--echo "No executable found in \"`dirname $exe`\"."
--exit 1
-+exec cyana
diff --git a/sci-chemistry/cyana/files/2.1-expire.patch b/sci-chemistry/cyana/files/2.1-expire.patch
deleted file mode 100644
index e18008286f68..000000000000
--- a/sci-chemistry/cyana/files/2.1-expire.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/inclan/unix.for.orig 2011-01-05 14:56:46.572193759 +0100
-+++ src/inclan/unix.for 2011-01-05 14:57:27.833627375 +0100
-@@ -206,11 +206,8 @@
- end if
- if (iwbeg.lt.0) then
- iwbeg=igttim
-- iexpir=(julday(12,31,2010)-julday(1,1,1970))*24*3600
-- if (iwbeg.gt.iexpir) call fatmsg ('License expired.')
-+ iexpir=iwbeg+100
- j=(iexpir-iwbeg)/(24*3600)
-- if (j.lt.1000)
-- * call wrnmsg ('License expires in '//plural(j,'day')//'.')
- end if
- iwall=igttim-iwbeg
- c print *,'iwall = ',iwall,iwbeg,idat,itim \ No newline at end of file
diff --git a/sci-chemistry/cyana/files/2.1-typo.patch b/sci-chemistry/cyana/files/2.1-typo.patch
deleted file mode 100644
index 3f011a9b2c28..000000000000
--- a/sci-chemistry/cyana/files/2.1-typo.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/cyana/putpro.f b/src/cyana/putpro.f
-index d4080f9..4490225 100644
---- a/src/cyana/putpro.f
-+++ b/src/cyana/putpro.f
-@@ -66,7 +66,7 @@ c ------------------------------------------------------ BMRB header
- * ' _Mol_residue_sequence',
- * ';'
- do i=1,nr,20
-- write (iunit,'(20A1))') (rcode(rnam(j)),j=i,min(nr,i+19))
-+ write (iunit,'(20A1)') (rcode(rnam(j)),j=i,min(nr,i+19))
- end do
-
- write (iunit,'(A)')
diff --git a/sci-chemistry/cyana/files/2.1-xiar.patch b/sci-chemistry/cyana/files/2.1-xiar.patch
deleted file mode 100644
index e8393253d7f6..000000000000
--- a/sci-chemistry/cyana/files/2.1-xiar.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- src/inclan/Makefile | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/inclan/Makefile b/src/inclan/Makefile
-index fc5a8bf..482d48f 100644
---- a/src/inclan/Makefile
-+++ b/src/inclan/Makefile
-@@ -35,7 +35,7 @@ clean:
-
- inclan.a: $(OBJS)
- rm -f $@
-- ar rc $@ $(OBJS)
-+ $(AR) rc $@ $(OBJS)
- if [ "$(RANLIB)" ]; then $(RANLIB) $@; fi
-
- inclan.o: inclan.for