summaryrefslogtreecommitdiff
path: root/sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild')
-rw-r--r--sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild b/sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild
new file mode 100644
index 000000000000..e344e71ef07e
--- /dev/null
+++ b/sci-chemistry/ParmEd/ParmEd-3.4.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parameter and topology file editor and molecular mechanical simulator engine"
+HOMEPAGE="https://parmed.github.io/ParmEd/html/index.html"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+distutils_enable_tests pytest